Services degraded
Incident Report for Melo
Resolved
The incident has been resolved.

Thanks for your understanding & sorry for any inconvenience this has caused.
Posted Mar 30, 2022 - 10:29 CEST
Identified
We have identified an issue impacting our platform. We are working on resolution with high priority.
Posted Mar 30, 2022 - 10:27 CEST
This incident affected: API.